Problem Mounting System Volume in Read-Write

A forum for help on TrueCrypt 7.1a problems. Note: the CipherShed team will not feel obligated to answer your questions. This is the community's task.
Forum rules
The original TC forums are down, so here you can ask the community for help with your TrueCrypt 7.1a installation. Note that the CipherShed team does not have the time, nor is it's purpose to answer your questions here. This is merely a new spot for the community to gather again, and for users to help eachother.

Problem Mounting System Volume in Read-Write

Postby keitolainen » Fri Jun 26, 2015 8:14 pm


This is probably a dumb question, but I'm having trouble mounting a system volume encrypted with ciphershed as read-write. I'm using arch linux, ciphershed 7.1a and the volume I'm trying to mount is a Windows 7 system partition. I can't for the life of me get this volume mounted with write permissions... what am I doing wrong? Here is the command line I'm running:

Code: Select all
sudo ciphershed -t /dev/sda1 /mnt/windows -m system --protect-hidden=no -k ""

I've tried using the --fs-options flag with "rw"; "defaults"; "user"; "uid=1000"; "umask=022" etc etc... But no luck. Any help would be appreciated.

Posts: 2
Joined: Fri Jun 26, 2015 8:04 pm

Re: Problem Mounting System Volume in Read-Write

Postby GigabyteProductions » Sat Jun 27, 2015 4:08 am

While it's mounted, run
Code: Select all
mount | grep '^\S\+ on /mnt/windows '
ls -ld /mnt/windows /mnt/windows/Windows /mnt/windows/Windows/explorer.exe
in a terminal and post the output. This is so we can see the various permissions on things regarding your mount to see what permission is causing the problem.

I suggest avoiding using CipherShed to call the final mount and use your system's mounting ability. I don't think it should be TrueCrypt's or CipherShed's responsibility to call the final mount. I think it should only be in charge of providing the block devices and let the user's environment take care of mounting. I think this is where the problem is originating. To "open" the TrueCrypt volume without mounting, run
Code: Select all
sudo ciphershed -t /dev/sda1 --filesystem=none -m system --protect-hidden=no -k ""
This will create the block device (most likely in a place like /dev/mapper/ciphershed), that you should be able to mount with your file manager as if it was a flash drive or another hard drive. I'm not sure if the block device's location varies on different Linux systems, but I've seen them in /dev/mapper/ciphershed in Debian-based systems. I think they go wherever dmsetup usually puts them.

If you're not using a graphical environment, and you'd like to mount on command line, run something along the lines of
Code: Select all
sudo mount /dev/mapper/ciphershedSOME_NUMBER /mnt/windows -t ntfs -o nodev,nosuid,noexec,fmask=177,dmask=077,uid=1000,gid=1000
This will mount it readable only to you, and doesn't allow execution of files directly off of the volume.

Also, I took the time to test this with a freshly setup TrueCrypt encrypted Windows system and opened it with a Linux system (both in a VM), and I've found that my way, and your way both work, so now I'm wondering if the ntfs driver on your system is intentionally mounting it as read-only due to corruption or a hard shutdown or something. You might want to check the last lines of 'dmesg' as soon as you mount to see if this is the case.
User avatar
Posts: 17
Joined: Sat Jun 07, 2014 8:00 pm
Location: USA

Re: Problem Mounting System Volume in Read-Write

Postby keitolainen » Sat Jun 27, 2015 2:06 pm

Thanks for your response and the work you put in to help narrow this down, it really helped me out. I've figured out what the problem was. There were two issues...

First: you were right, dmesg said the ntfs filesystem had a flag set and I needed to run a chkdsk on it. After I did that the mount flags changed from "ro" to "rw", but I still couldn't make changes to the filesystem.

Second: I was using the default ntfs driver in Arch, which apparently doesn't support writing. After I installed the ntfs-3g driver, it worked perfectly.

Thanks again, I'm glad this got sorted out.
Posts: 2
Joined: Fri Jun 26, 2015 8:04 pm

Return to Help

Who is online

Users browsing this forum: No registered users and 1 guest